注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

..、、的博客

..、、

 
 
 

日志

 
 

antlr.collections.AST.getLine()I异常解决方案  

2012-11-21 16:59:34|  分类: SSH |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
antlr.collections.AST.getLine()I异常解决方案

SSH组合完成后,执行hibernate的HQL查询时,报错:

java.lang.NoSuchMethodError: antlr.collections.AST.getLine()I

看来是antlr这个语法解析包出错

因为Struts自带的antlr-2.7.2.jar,比Hibernate3.3自带的antlr-2.7.6.jar的版本要低,故要删除前一个低版本的,, struts1.3 和2.1都带有antlr-2.7.2.jar ,,,下面我要把它们都清除了,由于myeclipse 添加的struts性能不是放在工程lib下的,而是myeclipse自带的,,所以删除比较麻烦,,我觉得最简单的做法应该是这样:

D:\MyEclipse8.6\MyEclipse-8.6\configuration\org.eclipse.osgi\bundles 下搜索antlr-2.7.2.jar

完成后能看到的,都删除掉,,(可能有些是在1.3下面的,有些是在2.1下面的)

然后在 D:\MyEclipse8.6\Common\plugins 搜索 *struts*.jar 会发现,出来三个

选中 一个文件,,打开方式选择压缩包,,我的winRAR的,

com.genuitec.eclipse.cross.easystruts.eclipse_8.6.0.me201007231647.jar 在lib下和data\1.3下要删除antlr-2.7.2.jar(这个是删除1.3里面的)

而再打开 com.genuitec.eclipse.struts2_8.6.0.me201007292038.jar data\2.1\core 下删除antlr-2.7.2.jar (这个是2.1里面的)

好了,,这个就从struts1.3和2.1中移除了,,因为这两个jar是common目录下的,所以删除了后,再运行myeclipse后, myeclipse就不能再从这两个包中找antlr-2.7.2.jar 并加载了

注意:如果程序已经运行过,则同时需要删除TOMCAT下的antlr-2.7.2.jar

  评论这张
 
阅读(264)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017